12/1/2021: OK folks, the new forum software is up and running

Update: 1/4/2022 I believe there is/was an issue with the registration process. I have made some adjustments to the settings. If you have problems, email me at: jim@eaglesinternational.net

Reminder: "quick links" menu offers you the best navigation on this forum -- you need to be logged in to see that menu (details in link below).


I have have updated the thread that discusses the new platform: https://eagles-international.net/forums ... fa10d60ea5 Please report any issues on this thread.

Jim

Mason's 1968 model 05

This is a public forum. This forum will be a place to show your Project Eagle and updates on progress you have made. Please make one thread with your project and put all updates in the same thread. Sorry... Eagles only.
BUTTON_POST_REPLY
Eagle obsessed
PostsCOLON 288
JoinedCOLON Thu Jun 14, 2018 11:37 am
Bus ModelCOLON 1968 model 05 Eagle series 60 and B500
LocationCOLON McCook NE

Re: Mason's 1968 model 05

Post by Eagle obsessed »

Well, a lot of things have happened since the 2nd, a lot of little technical details as well as visible details.

Put both windshields in, cracked one :evil: :evil: I guess it is common to crack one ? Any way I think John zahn sold me model 15 gasket, we put the next one in with the old gasket and it worked ok, but there is one spot where the window doesn't match the frame. Again, :evil: :evil:

So then tonight took for first drive on highway, engine running great, transmission shifting perfectly, how ever our steering assist is acting really weird. It's almost like you have to steer 3 Seconds ahead of what you want the wheels to do. Maybe not enough pressure? :cry: sigh

This would be the only thing keeping us from getting on the road this weekend for a 4 hour family camping trip.

So I am a little frustrated.

Anyone have a Ross power steering box I can buy lol


Mason
Attachments
IMG_20200707_214414118_HDR.jpg
IMG_20200707_211039445.jpg
1968 05 Eagle 8v71 with roadranger 9 speed,
04/25/19 starting upgrade to series 60! and B500
User avatar
beltguy
Site Admin
Site Admin
PostsCOLON 2486
JoinedCOLON Wed Oct 08, 2008 4:39 am
FMCA #COLON F246286
Bus ModelCOLON 1985 Eagle 10 with Series 60 and Eaton AutoShift 10 speed transmission
LocationCOLON Evergreen, CO
CONTACTCOLON

Re: Mason's 1968 model 05

Post by beltguy »

Mason, sounds like you have reached a frustration point. Most of us have been there many times. Hang in there.

I can't tell what type of steering you have. If it is air assisted, you will probably want to plan for a standard PS box. If you have a PS box, you should look at the mounting bracket.

Eagle had a factory service bulletin for Model 10 buses because of a problem with the factory bracket -- see:
https://eagles-international.net/forums ... 556#p30063

Since you have a model 05 that would probably not affect you, but I thought I would mention it.

Jim
Jim Shepherd
Evergreen, CO
'85 Eagle 10 with Series 60 & Eaton AutoShift 10 speed transmission SOLD
2005 Dodge 2500 with 5.9 Cummins and 6 speed manual 2014 Passport 26 foot trailer
Bus Project pages: http://beltguy.com/Bus_Project/busproject.htm
Blog: http://beltguy.com/blog/
Email: jim@eaglesinternational.net NOTE this email box is only for general correspondence and not technical advice
User avatar
beltguy
Site Admin
Site Admin
PostsCOLON 2486
JoinedCOLON Wed Oct 08, 2008 4:39 am
FMCA #COLON F246286
Bus ModelCOLON 1985 Eagle 10 with Series 60 and Eaton AutoShift 10 speed transmission
LocationCOLON Evergreen, CO
CONTACTCOLON

Re: Mason's 1968 model 05

Post by beltguy »

Mason, based on your post on BCM, we now know that you have hydraulic power assist. You are getting decent advice. One person talked about being sure that you steering is centered. I think that is important with a PS box, but not the PS assist.

All of my searching discussed air assist PS for Eagles and that system sounds like it sucks.

It sounds like you drove the bus with the assist deactivated and it drove well. That would tend to eliminate any linkage/steering component issues. That said, I would still check things like tie rod ends.

I was hoping that my parts manual would cover power assist, but no such luck. The picture below shows a very basic system that is fundamentally the same as yours (I think).
linkage-steering-power-assist-1.jpg
linkage-steering-power-assist-1.jpg (78.21 KiB) Viewed 1905 times
At first glace the system seems pretty simple. That said, I worked on one in a 57 Chevy and they are a bit cranky when they get old. The control valve is the critical component and if the valving components are worn, it causes a problem. Also the linkage between the mechanical steering box and the control valve must have almost no play, or the system will "hunt". Since you have the hydraulics in place, I would vote to convert to a PS box.

We don't have a lot of information about PS boxes, but the following is about the best I could find:
https://eagles-international.net/forums ... 0e6#p22852

Jim
Jim Shepherd
Evergreen, CO
'85 Eagle 10 with Series 60 & Eaton AutoShift 10 speed transmission SOLD
2005 Dodge 2500 with 5.9 Cummins and 6 speed manual 2014 Passport 26 foot trailer
Bus Project pages: http://beltguy.com/Bus_Project/busproject.htm
Blog: http://beltguy.com/blog/
Email: jim@eaglesinternational.net NOTE this email box is only for general correspondence and not technical advice
Eagle obsessed
PostsCOLON 288
JoinedCOLON Thu Jun 14, 2018 11:37 am
Bus ModelCOLON 1968 model 05 Eagle series 60 and B500
LocationCOLON McCook NE

Re: Mason's 1968 model 05

Post by Eagle obsessed »

Well last week was... interesting.

let me begin by posting what i posted on BCM.
ok, I am finally back. Sorry for the wait. Last week was quite a ride.

Let me just start at the beginning.

So after my last post, I was Down in the barn and I decided to work on bleeding the system, figuring it still had air in it. After jacking up the bus, I went around and pushed on the tire and was astonished to find that the tire would move both ways about 2-3 inches. Crawling underneath I found the problem, and took a short video of it here. https://youtu.be/GnCo9N9KGYc
I took it from the curb side, in the foreground you can see the hydraulic assist cylinder, what is moving is the 90 degree arm used to transfer longitudinal motion to side to side motion. Please take time to look at the 3 sec vid, it will answer many questions.

So basically we were 1 rusty 1/2" bolt from being in the ditch... :-[

Well that was a shock to find.

MY Hypothesis: There are 4 bolts holding this bracket on, I am sure 3 were completely rusted through and the whole assembly was being held on by one bolt and some rust. As we were maneuvering out of our driveway the additional pressure from the hydraulic assist went ahead and broke the rust so it was hanging from 1 bolt. As you recall, the hydraulic assist was not working with the 8v71.

Which leads to the crazy steering problem we had.

This was Wednesday morning. So i tore into that and around 5 pm had it all back together with new bolts, new spacers, and a lot of reinforcement above the spacers.

Took it for a test drive that evening, everything worked great, but the steering wheel still had 2 inch slop either way in it, but it was solid so drivable.

On thursday we fabricated bunks, back bed platform, counter top, some kind of seating, and fridge mounts and we left around 3 for a 'relaxing vacation'

But we got it on the road! :o

but now i can start going to bed at a regular time again lol

and my phone stopped working so no pictures till I get that backed up.
That pretty much explains the steering problem.

I'll have more pictures soon and more explanation.

mason
1968 05 Eagle 8v71 with roadranger 9 speed,
04/25/19 starting upgrade to series 60! and B500
User avatar
rusty
Moderator
Moderator
PostsCOLON 1498
JoinedCOLON Thu Oct 09, 2008 3:22 pm
FMCA #COLON F341087
Bus ModelCOLON 1972 05 completed 2003
1994 15/45 in progress
LocationCOLON Johnstown Co.

Re: Mason's 1968 model 05

Post by rusty »

That's a little scary. I know you have thought of this but I would spend some time looking for more rusted components on the front end.
Wayne
Eagle obsessed
PostsCOLON 288
JoinedCOLON Thu Jun 14, 2018 11:37 am
Bus ModelCOLON 1968 model 05 Eagle series 60 and B500
LocationCOLON McCook NE

Re: Mason's 1968 model 05

Post by Eagle obsessed »

Yes, Wayne , next up is fixing other side, but I had a WWAI moment and decided to install a power steering box. I am planning on using the bluebird box, although it is a unique configuration.

Here are some pictures so far


As a side note, I think we only shifted into 6th twice on our 8 hour trip, both times right at or right above 70 mph. Right at 1350 rpm at 70mph.

Other wise we were in 5th at 1475 rpm for 65, 66 mph.

So very pleased with the rear end gearing, this thing wants to roll! And it will be awesome to drive once it steers correctly.

Max temp was around 200 deg., but we didn’t have any hard grades and the outside temp was 85 max. I’m pretty sure thermostats don’t open til 200...

And lost one belt on the way back, not sure why, but maybe we will upgrade to a little bigger, wider, tensioner.

Jakes and cruise worked successfully, but cruise is not hooked to brakes yet so we did not use. And jakes seem to only be 2 stages. But over all a pleasing trip.


Mason
Attachments
311CD334-4DF8-4CA5-8D45-7A4E2F23FAE3.jpeg
C9FF02A6-7FAA-461D-A6D0-57D8482369D9.jpeg
25A23AD4-448E-4321-80D8-B9240A6A9C63.jpeg
1968 05 Eagle 8v71 with roadranger 9 speed,
04/25/19 starting upgrade to series 60! and B500
User avatar
rusty
Moderator
Moderator
PostsCOLON 1498
JoinedCOLON Thu Oct 09, 2008 3:22 pm
FMCA #COLON F341087
Bus ModelCOLON 1972 05 completed 2003
1994 15/45 in progress
LocationCOLON Johnstown Co.

Re: Mason's 1968 model 05

Post by rusty »

Great news. Glad your trip went well. If you are going to change to the bluebird steering box I mite have a deal for you. Somehow I ended up with a new steering box from the left overs at the end if the bluebird factory demise. It is yours but you have to pick it up at my place or maybe we could meet have way some where in eastern Colorado. See if there is some numbers on the box to see if they are the same.
Wayne
User avatar
ericbsc
Moderator
Moderator
PostsCOLON 742
JoinedCOLON Wed Dec 24, 2008 8:31 pm
FMCA #COLON 12345678
Bus ModelCOLON 1973 Eagle 05
LocationCOLON Boiling Springs, SC

Re: Mason's 1968 model 05

Post by ericbsc »

Sounds like you are ready for Branson!! It is worth the trip even in a car!!
DSC_9097.JPG
Eric Brown
Spartanburg, SC
1973 05
Series 60 allison 4000MHP
Eagle obsessed
PostsCOLON 288
JoinedCOLON Thu Jun 14, 2018 11:37 am
Bus ModelCOLON 1968 model 05 Eagle series 60 and B500
LocationCOLON McCook NE

Re: Mason's 1968 model 05

Post by Eagle obsessed »

Ok, looks like I’m pretty bad at replying. :oops:

Wayne, at this point since we had this box already, we installed it, however I may take up your offer on your box anyway, we will see.

Eric, thanks for the invite. Not sure if it will happen though. This is a pretty busy time of year for us.

I did get the box installed, threw the floor in and we took it for a drive, now it steers as it should, however the steering wheel is extremely hard to turn just sitting. Not sure if there is still to much air in the system or what. Besides that, i have been to busy to touch the bus.

That should change soon though. Next project is to completely seal the front end.

Mason
Attachments
7D1BB40C-A6C7-4CEF-8E55-91A901BD6B25.jpeg
1968 05 Eagle 8v71 with roadranger 9 speed,
04/25/19 starting upgrade to series 60! and B500
User avatar
ericbsc
Moderator
Moderator
PostsCOLON 742
JoinedCOLON Wed Dec 24, 2008 8:31 pm
FMCA #COLON 12345678
Bus ModelCOLON 1973 Eagle 05
LocationCOLON Boiling Springs, SC

Re: Mason's 1968 model 05

Post by ericbsc »

Shouldn't be hard to turn if both the unit and ps pump came from the same bus. Check for air in the system. Also, if you rev it up a little does it turn easier?? If so, you may need a higher flow, or pressure pump.
Eric Brown
Spartanburg, SC
1973 05
Series 60 allison 4000MHP
BUTTON_POST_REPLY